1981 124 Spider not starting

The forum for all of your technical questions on your classic FIAT autos
124spider-Malta
Posts: 7
Joined: Sun Nov 10, 2019 9:37 am
Last Name: Sant
First Name: Duncan

1981 124 Spider not starting

Post by 124spider-Malta » Sun Nov 10, 2019 5:03 pm

Hi all, new member here from Malta (Europe).

I have a 1981 2000cc 124 Spider. The car is in great shape. Last used it 10 days ago with no problems. Went to start it today but wouldn't start. Engine turns over and has spark (I tested for spark) so it not a problem with the ignition, so I am assuming it is fuel related. Since it is the fuel injection model I am thinking maybe fuel pump? Or maybe wiring / relay? How likely are they to fail? Is there anything else I can check? Been off repairing cars for a while now, so trying to find my feet again on this classic.

Any help really appreciated.
User avatar
atruscott
Posts: 707
Joined: Sat Mar 19, 2016 10:40 pm
Last Name: Truscott
First Name: Andy

Re: 1981 124 Spider not starting

Post by atruscott » Sun Nov 10, 2019 9:09 pm

See if you've got power to the pump when cranking (it's just in front of the rear axle, on the driver's side, under the car). If power, possible it's the pump (have you ever replaced it?). If there's no power.... go through the helper at: https://www.mirafiori.com/forum/viewtop ... 70&t=96392

Actually - just go through the helper anyway ;)
1960 Autobianchi Bianchina Transformabile
1970 238 Camper OHV
1974 124 Wagon TC
1974 124 Special TC
1975 124 Sport Coupe
1976 124 Sport Spider (The Racer)
1981 Spider 2000 (The Resurrected)
1985 Pininfarina Azzurra
2017 124 Spider Abarth Elaborazione
User avatar
bartigue
seimila club
Posts: 6440
Joined: Sat Jan 23, 2016 11:49 pm
Last Name: Artigue
First Name: Bradley
Contact:

Re: 1981 124 Spider not starting

Post by bartigue » Sun Nov 10, 2019 9:13 pm

100% agree on the helper guide, get a multimeter and test things.

Fuel pump test is pretty easy to do regardless, put the key in the run position, pop the cap off the top of the AFM, rotate the little arm slightly. Once it moves even a couple of mm you should hear the fuel pump running.
-----------------------------------------------------------
Brad Artigue
1969, 1969, 1970, 1979, 1980, 1981, 1982, and 1982 124 Spiders
1969, 1970 850 Spiders
77 X1/9
http://fiat.artigue.com
User avatar
friedman
mille club
Posts: 1946
Joined: Wed Aug 24, 2016 8:13 am
Last Name:

Re: 1981 124 Spider not starting

Post by friedman » Mon Nov 11, 2019 8:28 am

Brad, I think you mean pop the top of the air filter and push in on the flap, not the top of the AFM itself.
Carl in Virginia
75 spider
83 Bertone
User avatar
bartigue
seimila club
Posts: 6440
Joined: Sat Jan 23, 2016 11:49 pm
Last Name: Artigue
First Name: Bradley
Contact:

Re: 1981 124 Spider not starting

Post by bartigue » Mon Nov 11, 2019 10:14 am

friedman wrote:
Mon Nov 11, 2019 8:28 am
Brad, I think you mean pop the top of the air filter and push in on the flap, not the top of the AFM itself.
Either way. Most AFM caps aren't glued on, so easier to just pop it off and manually turn the thing.
-----------------------------------------------------------
Brad Artigue
1969, 1969, 1970, 1979, 1980, 1981, 1982, and 1982 124 Spiders
1969, 1970 850 Spiders
77 X1/9
http://fiat.artigue.com
User avatar
atruscott
Posts: 707
Joined: Sat Mar 19, 2016 10:40 pm
Last Name: Truscott
First Name: Andy

Re: 1981 124 Spider not starting

Post by atruscott » Mon Nov 11, 2019 11:39 am

... and the fuel pump is #9 in the helper ;)
1960 Autobianchi Bianchina Transformabile
1970 238 Camper OHV
1974 124 Wagon TC
1974 124 Special TC
1975 124 Sport Coupe
1976 124 Sport Spider (The Racer)
1981 Spider 2000 (The Resurrected)
1985 Pininfarina Azzurra
2017 124 Spider Abarth Elaborazione
124spider-Malta
Posts: 7
Joined: Sun Nov 10, 2019 9:37 am
Last Name: Sant
First Name: Duncan

Re: 1981 124 Spider not starting

Post by 124spider-Malta » Mon Nov 11, 2019 2:50 pm

Thanks everyone! Managed to get under the car and teated for electricity at the pump, which I had. With the pump disconnected the car started right up, although stuttering (prob due to low fuel pressure). I then cleaned the connectors properly and connected everything. And it is working again! Pump is working and car is purring like a kitten again! Might as well buy a fuel pump and leave it as spare as it looks like it is on it’s original pump. Now on to the next issue, which is the seatbelt light. Took the belt buckle off and found the wites are cut! Tried prying the buckle open to replace the wires but couldn’t manage. Anyone know if it can be opened?
Attachments
35CF5FBA-D1F0-4489-A9D4-A72E6D2C996E.jpeg
35CF5FBA-D1F0-4489-A9D4-A72E6D2C996E.jpeg (1.7 MiB) Viewed 119 times
CD28B331-F613-4612-95AC-B3350B2C3756.jpeg
CD28B331-F613-4612-95AC-B3350B2C3756.jpeg (1.98 MiB) Viewed 119 times
A1FDF140-D4F7-4561-AF6C-07F7216813AA.jpeg
A1FDF140-D4F7-4561-AF6C-07F7216813AA.jpeg (2.03 MiB) Viewed 119 times
B81EDFF7-65BA-4C39-A6CA-0D2B58ED4112.jpeg
B81EDFF7-65BA-4C39-A6CA-0D2B58ED4112.jpeg (2.06 MiB) Viewed 119 times
User avatar
friedman
mille club
Posts: 1946
Joined: Wed Aug 24, 2016 8:13 am
Last Name:

Re: 1981 124 Spider not starting

Post by friedman » Mon Nov 11, 2019 3:54 pm

You really don't want to go messing with the seatbelt hardware. No one likes seatbelt lights and buzzers so that's probably why it was cut. If you need a light to remind you to put your seatbelt on then you shouldn't be driving!

But, Brad can probably tell you how to do this repair.
Carl in Virginia
75 spider
83 Bertone
124spider-Malta
Posts: 7
Joined: Sun Nov 10, 2019 9:37 am
Last Name: Sant
First Name: Duncan

Re: 1981 124 Spider not starting

Post by 124spider-Malta » Mon Nov 11, 2019 4:51 pm

friedman wrote:
Mon Nov 11, 2019 3:54 pm
You really don't want to go messing with the seatbelt hardware. No one likes seatbelt lights and buzzers so that's probably why it was cut. If you need a light to remind you to put your seatbelt on then you shouldn't be driving!

But, Brad can probably tell you how to do this repair.
I always wear a seatbelt, the issue is that with the wires cut the light stays on and buzzer keeps on buzzing, hence why I want to repair it! The wires look like they hardened, they don’t look like they were cut intentionally.
User avatar
bartigue
seimila club
Posts: 6440
Joined: Sat Jan 23, 2016 11:49 pm
Last Name: Artigue
First Name: Bradley
Contact:

Re: 1981 124 Spider not starting

Post by bartigue » Mon Nov 11, 2019 8:35 pm

Nice car. Crazy mirrors!

Personally I'd never try to fix the seatbelt latch - it will fail in the closed position (and probably already is). I don't mind the warning lamp coming on for a few seconds or the buzzer dinging when I have the doors open, all of which is explained in the electrical troubleshooting guide for the Spider 2000, which you can download in the 124 section of the library of this forum. In the troubleshooting guide on page 46 it shows the routing of wiring for the seat belt assembly; notable:

- when the belt is engaged the switch is open; therefore, a cut wire should be perpetually open and is not causing your issue. someone probably did this trying to diagnose it, assuming engaged would close the switch, not open it. they was wrong.

- the seat belt has one black wire that goes to connector C18 which goes to the horn and wiper relays...these are all grounded at G3 under the dash.

- the seat belt has one pink wire that goes into C18 and comes out pink and black. This connects to the seatbelt relay in the relay tray.

- The seatbelt relay connects via dark blue and red to the seatbelt timer and the seatbelt indicator lamp.

- page 48 has a full description of seatbelt warning operation
-----------------------------------------------------------
Brad Artigue
1969, 1969, 1970, 1979, 1980, 1981, 1982, and 1982 124 Spiders
1969, 1970 850 Spiders
77 X1/9
http://fiat.artigue.com
Post Reply

Who is online

Users browsing this forum: skpens and 56 guests