Search found 64 matches

by Funcar
Thu Aug 01, 2019 7:06 am
Forum: Tech Questions and Advice
Topic: Engine fan power. 73 1608.
Replies: 14
Views: 4812

Re: Engine fan power. 73 1608.

You are absolutely right Dave. I intend to fix it correctly. Currently try to source the connector block.
by Funcar
Tue Jul 30, 2019 9:50 am
Forum: Tech Questions and Advice
Topic: Engine fan power. 73 1608.
Replies: 14
Views: 4812

Re: Engine fan power. 73 1608.

Thanks for your response Brad. The wiring in this car is pretty much how I recieved it. To me it looks like there are too many wires and as I know that this car was a combined 73 and 75 or higher car I think it has both wiring harnesses. I could be totally wrong as I don't have any other Spiders to ...
by Funcar
Mon Jul 29, 2019 11:46 am
Forum: Tech Questions and Advice
Topic: Engine fan power. 73 1608.
Replies: 14
Views: 4812

Re: Engine fan power. 73 1608.

I repaired the burned wire with a new connector . I used the old relay as it didn't seem damaged. The plastic holder needs to be replaced. Can someone tell me how to remove it from the fender or how it is connected. I would think I can source from a vendor or some one that sells parts. I activated t...
by Funcar
Sat Jul 27, 2019 6:05 pm
Forum: Tech Questions and Advice
Topic: Engine fan power. 73 1608.
Replies: 14
Views: 4812

Re: Engine fan power. 73 1608.

Thanks again on helping me with my rolling restoration.
by Funcar
Sat Jul 27, 2019 4:26 pm
Forum: Tech Questions and Advice
Topic: Engine fan power. 73 1608.
Replies: 14
Views: 4812

Re: Engine fan power. 73 1608.

Dave Thank you for pointing me in the right direction to find the problem. https://i.imgur.com/Yoqf3PV.jpg?1 Here is a picture of the relay. The green wire was burned and easily pulled free. It was actually fried.That was the problem. https://i.imgur.com/9WfnN1M.jpg?1 Here is a picture of the 5 wire...
by Funcar
Sat Jul 27, 2019 8:32 am
Forum: Tech Questions and Advice
Topic: Engine fan power. 73 1608.
Replies: 14
Views: 4812

Engine fan power. 73 1608.

Yes I know that there is a lot of information on the engine fan and how it works. However I would ask for some advice on getting it running. Initially when I got the car very little of the electrical was working but managed to clean grounds etc. and got most things working. To get the engine fan wor...
by Funcar
Wed Jun 26, 2019 6:14 pm
Forum: F/I/A/T B/S
Topic: Ladder Bumpers - what was the first year?
Replies: 35
Views: 6381

Re: Ladder Bumpers - what was the first year?

The battery is in the trunk. I don't see any evidence that the battery was originally in the engine bay or that the trunk was alerted to accept it??. I am not very good at reading the electrical diagrams and the 73 schematic eludes me but I have a75 version that seems to get most of it. There seems ...
by Funcar
Wed Jun 26, 2019 5:49 am
Forum: F/I/A/T B/S
Topic: Ladder Bumpers - what was the first year?
Replies: 35
Views: 6381

Re: Ladder Bumpers - what was the first year?

Brad...your comment made me real dogon proud of my beautiful mysterious Italian "cur"! The tail shows it as a 1600. Cgranju...don't forget this car was restored over 30 years ago and i really don't think there was any fraudulent intentions or consideration at that time. The firewall stamp has not be...
by Funcar
Mon Jun 24, 2019 7:40 am
Forum: F/I/A/T B/S
Topic: Ladder Bumpers - what was the first year?
Replies: 35
Views: 6381

Re: Ladder Bumpers - what was the first year?

I have a 73 Fiat Spider with the latter style tube bumpers. There is no Vin# plate . The stamp on the firewall shows the Vin# 124 BS * 0055864. The motor plate # 125BC040 0648682. https://i.imgur.com/vSLICoC.jpg?1 https://i.imgur.com/xiy3rZc.jpg?2 https://i.imgur.com/2AoEKxw.jpg?1 https://i.imgur.co...
by Funcar
Fri Jun 14, 2019 6:58 am
Forum: Tech Questions and Advice
Topic: 73 1608 Engine with limited power
Replies: 13
Views: 1227

Re: 73 1608 Engine with limited power

Finally co-ordinated with my friend to complete the the compression and timing tests. I have the timing belt cover off from last year. Both cam wheels were dead on there marks as was the auxiliary shaft wheel. So we proceeded with the compression test. #1 125 # 2 95 #3 120 #4 125. I really don't kno...